mercredi 31 décembre 2014

PHPUnit test classes with camel case or underscore

When writing test cases inthe xUnit style that PHPUnit follows it seems that everyone follows the camel case convention for function names:



public function testObjectHasFluentInterface()
{
// ...
}


I have been naming my methods with a more "eloquent" PHPSpec style:



public function test_it_has_a_fluent_interface()
{
// ...
}


Will this style create problems for me in the future? Personally I find it vastly more readable and easy to come back to.


Aucun commentaire:

Enregistrer un commentaire